10.03.2019 - Round 1 results of our "A Love Letter For FreeBASIC" game dev competition have been published. Please be sure to check the results thread: http://games.freebasic.net/forum/index.php?topic=629.0. Don't forget that the competition is continuing with a round 2, lasting till 29th of April, 300 USD first prize. Stay tuned!

Author Topic: Good IDE  (Read 3685 times)

ecxjoe

  • Novice
  • ***
  • Posts: 78
    • View Profile
    • Delta Code
Good IDE
« on: October 21, 2011, 10:48:14 PM »
http://www.geany.org/

This is now my favorite IDE for everything. And it supports Freebasic!

Lachie Dazdarian

  • Double dipper
  • Administrator
  • Forum Sage
  • *****
  • Posts: 1308
    • Yahoo Instant Messenger - lachie13
    • View Profile
    • The Maker Of Stuff
    • Email
Re: Good IDE
« Reply #1 on: October 22, 2011, 03:49:33 AM »
Having problems connecting it with my copy of fbc. Could you tell me how did you set it up?
"Things like Basic and Free Basic provide much-needed therapy and a return to sanity and a correct appreciation of people. The arrogant folk really hate a word like 'Basic' - fine, and good riddance." ~ pragmatist

ecxjoe

  • Novice
  • ***
  • Posts: 78
    • View Profile
    • Delta Code
Re: Good IDE
« Reply #2 on: October 22, 2011, 10:09:56 AM »
Are you on Windows or Linux?

ecxjoe

  • Novice
  • ***
  • Posts: 78
    • View Profile
    • Delta Code
Re: Good IDE
« Reply #3 on: October 22, 2011, 10:14:55 AM »
In both cases I didn't have to do anything. Make sure you press F8 to compile first and then F5 to run.

Maybe you need fbc in your environment path? That's how Freebasic is set up for me.
« Last Edit: October 22, 2011, 10:17:39 AM by ecxjoe »

Lachie Dazdarian

  • Double dipper
  • Administrator
  • Forum Sage
  • *****
  • Posts: 1308
    • Yahoo Instant Messenger - lachie13
    • View Profile
    • The Maker Of Stuff
    • Email
Re: Good IDE
« Reply #4 on: October 22, 2011, 11:40:56 AM »
I get "Project failed..." when I try to compile.

The path to fbc is set (which I had to do with copy and paste - no directory picker):



I don't know what else I need to do. I mean, I good IDE should allow me to set a path to my compiler and that's it. It should compile my sources where ever they are, and the executables should be produced where the source is.
"Things like Basic and Free Basic provide much-needed therapy and a return to sanity and a correct appreciation of people. The arrogant folk really hate a word like 'Basic' - fine, and good riddance." ~ pragmatist

ecxjoe

  • Novice
  • ***
  • Posts: 78
    • View Profile
    • Delta Code
Re: Good IDE
« Reply #5 on: October 22, 2011, 02:21:57 PM »
Try leaving the working directory empty and prepend the path to the command, something like this: C:\Program Files (x86)\FreeBASIC\fbc -w all "%f"

ecxjoe

  • Novice
  • ***
  • Posts: 78
    • View Profile
    • Delta Code
Re: Good IDE
« Reply #6 on: October 22, 2011, 02:33:47 PM »
If you have the Freebasic path in your environment settings then you shouldn't need to set anything in the build options. My settings are the same as yours but with the working directory empty. I get an error when I try to put the path in there too.